Motore di ricerca datesheet componenti elettronici
  Italian  ▼
ALLDATASHEETIT.COM

X  



RFC2K Reseller

ResellerIl numero della parteProduttore elettroniciSpiegazioni elettroniciPriceQty.
BuyNow

Master Electronics
H8270RFCA

TE Connectivity Res Metal Film 270 Ohm 1% 0.25W(1/4W) ±50ppm/°C Conformal AXL Bandoliered
RoHS : Compliant
15,000 : $0.314
10,000 : $0.3148
7,500 : $0.3367
5,000 : $0.3376
2,500 : $0.3548
1,000 : $0.365
500 : $0.3736
250 : $0.3797
450
RFC-2216

Quest Technology International Inc Cable Assembly UHF Plug x2 RG-58A/U Cbl 10ft. Non Booted | Quest Technology International Inc. RFC-2216
RoHS : Compliant
250 : $32.08
100 : $32.24
50 : $32.4
25 : $33.5
10 : $34.61
5 : $35.91
1 : $39.58
6
H4P33RFCA

TE Connectivity H4P 33R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H882RFCA

TE Connectivity H8 82R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H4P27RFCA

TE Connectivity H4P 27R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
SRFC5CAP

Tripp Lite SRFC5CAP
RoHS : Compliant
1,000 : $12.16
500 : $12.32
250 : $12.66
100 : $13.2
50 : $13.79
25 : $14.44
5 : $15.93
0
SEALINTRFCL MDM-15SPERMIL-

ITT Interconnect Solutions
RoHS : Compliant
500 : $2.29
375 : $2.34
250 : $2.5
125 : $3.34
0
H4P10RFCA

TE Connectivity H4P 10R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H4P430RFCA

TE Connectivity H4P 430R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H4P47RFCA

TE Connectivity Res Metal Film 47 Ohm 1% 1W ±50ppm/°C Conformal Coated AXL Bandoliered
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
RFC-480S-PN-4TX

Phoenix Contact RFC 480S PN 4TX
RoHS : Compliant
10 : $7,165.4
1 : $7,387.01
0
H843RFCA

TE Connectivity H8 43R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H4P56RFCA

TE Connectivity H4P 56R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H836RFCA

TE Connectivity H8 36R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H4P16RFCA

TE Connectivity H4P 16R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0

Avnet Americas
RFCM3328PCBA-410

Qorvo RFCM3328 45MHz to 1218MHz GaAs / GaN Power Doubler Amplifier Module Evaluation Board - Bag (Alt: RFCM3328PCBA-410)
RoHS : Not Compliant
16 : $304.6875
8 : $312.5
4 : $320.7237
2 : $329.39188
1 : $348.2143
0
H4P33RFCA

TE Connectivity - Boxed Product (Development Kits) (Alt: 1-1879621-3)
RoHS : Compliant
50,000 : $0.44721
25,000 : $0.45714
10,000 : $0.50527
5,000 : $0.54514
500 : $0.57857
0
H882RFCA

TE Connectivity - Boxed Product (Development Kits) (Alt: 2-1879625-3)
RoHS : Compliant
50,000 : $0.33677
25,000 : $0.34424
10,000 : $0.38049
5,000 : $0.41051
500 : $0.43568
0
MFM-062RFC

Amphenol Corporation - Bulk (Alt: MFM062RFC)
RoHS : Not Compliant
0
MFM-072RFC-011

Amphenol Corporation - Bulk (Alt: MFM072RFC011)
RoHS : Not Compliant
0
ACCRFCL13BB1

Vishay Intertechnologies - Bulk (Alt: ACCRFCL13BB1)
RoHS : Not Compliant
160 : $56.81325
80 : $58.3688
40 : $58.6666
20 : $58.9644
10 : $64.74
0
ACCRFCOLLRSSD20AAV

Vishay Intertechnologies - Bulk (Alt: ACCRFCOLLRSSD20AAV)
RoHS : Not Compliant
16 : $17.44275
8 : $18.2966
4 : $18.38995
2 : $18.4833
1 : $19.45
0
IRFC37N50AB

Vishay Intertechnologies - Bulk (Alt: IRFC37N50AB)
RoHS : Compliant
3,520 : $13.26127
1,760 : $13.33034
880 : $13.39941
440 : $13.46848
220 : $13.53754
0
CRFC-1256/60-A

Omega Engineering HIGH TEMPERATURE, LOW MASS, VACUUM FORMED CERAMIC RADIANT FULL CYLINDER HEATERS - Bulk (Alt: CRFC-1256/60-A)
RoHS : Not Compliant
1 : $395.08
0
ACCRFCOLLRSSD25AAV

Vishay Intertechnologies - Bulk (Alt: ACCRFCOLLRSSD25AAV)
RoHS : Not Compliant
16 : $17.44275
8 : $18.2966
4 : $18.38995
2 : $18.4833
1 : $19.45
0
CAS21C821KARFC

KEMET Corporation Ceramic Suppression Capacitor, 820 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2220 [5650 Metric] - Tape and Reel (Alt: CAS21C821KARFC)
RoHS : Compliant
1,000 : $1.27367
0
228ADS2ARFCBBC

CTS Corporation - Trays (Alt: 228ADS2ARFCBBC)
RoHS : Compliant
40,000 : $1.323
20,000 : $1.32975
10,000 : $1.3365
5,000 : $1.34325
1,000 : $1.35
0
228ADS2ARFCMSE

CTS Corporation - Trays (Alt: 228ADS2ARFCMSE)
RoHS : Compliant
40,000 : $1.323
20,000 : $1.32975
10,000 : $1.3365
5,000 : $1.34325
1,000 : $1.35
0
228ADS2ARFCRC

CTS Corporation - Trays (Alt: 228ADS2ARFCRC)
RoHS : Compliant
40,000 : $1.323
20,000 : $1.32975
10,000 : $1.3365
5,000 : $1.34325
1,000 : $1.35
0
228AMVARFCMBBR

CTS Corporation - Trays (Alt: 228AMVARFCMBBR)
RoHS : Compliant
43,200 : $1.1466
21,600 : $1.15245
10,800 : $1.1583
5,400 : $1.16415
1,350 : $1.17625
0

Newark
MFR3-56RFC

TT Electronics Welwyn Components Res, 56R, 1%, 400Mw, Axial, Metal Film; |Tt Electronics/welwyn MFR3-56RFC
RoHS : Compliant
10 : $0.186
20 : $0.081
30 : $0.065
50 : $0.049
100 : $0.038
250 : $0.028
500 : $0.022
1,000 : $0.019
33,870
MFR3-33RFC

TT Electronics Welwyn Components Res, 33R, 1%, 400Mw, Axial, Metal Film; |Tt Electronics/welwyn MFR3-33RFC
RoHS : Compliant
10 : $0.186
20 : $0.081
30 : $0.065
50 : $0.049
100 : $0.038
250 : $0.028
500 : $0.022
1,000 : $0.019
28,620
MFR3-560RFC

TT Electronics Welwyn Components Metal Film Resistor, 560 Ohm, 400Mw, 1%, Axial Leaded; Resistance:560Ohm; Product Range:Mfr Series; Power Rating:400Mw; Resistance Tolerance:± 1%; Resistor Case/Package:Axial Leaded; Voltage Rating:200V; Product Diameter:2Mm Rohs Compliant: Yes
RoHS : Compliant
1 : $0.13
10 : $0.069
25 : $0.057
50 : $0.046
100 : $0.032
500 : $0.025
1,000 : $0.02
2,500 : $0.017
17,825
MFR3-390RFC

TT Electronics Welwyn Components Through Hole Metal Film Resistor, Mfr Se; |Tt Electronics/welwyn MFR3-390RFC
RoHS : Compliant
10 : $0.164
20 : $0.133
30 : $0.102
50 : $0.099
100 : $0.095
250 : $0.093
500 : $0.091
1,000 : $0.089
7,474
RFC0810B-104KE

Coilcraft Inc |Coilcraft RFC0810B-104KE
RoHS : Compliant
1 : $1.64
10 : $1.41
25 : $1.3
50 : $1.18
100 : $1.05
500 : $0.976
1,000 : $0.929
2,500 : $0.859
158
RFC0807B-824KE

Coilcraft Inc |Coilcraft RFC0807B-824KE
RoHS : Compliant
1 : $1.16
10 : $0.994
25 : $0.911
50 : $0.822
100 : $0.733
500 : $0.683
1,000 : $0.651
2,500 : $0.602
149
RFC1010B-104KE

Coilcraft Inc |Coilcraft RFC1010B-104KE
RoHS : Compliant
1 : $1.63
10 : $1.4
25 : $1.31
50 : $1.18
100 : $1.04
500 : $0.989
1,000 : $0.939
2,500 : $0.89
149
RFC0810B-275KE

Coilcraft Inc |Coilcraft RFC0810B-275KE
RoHS : Compliant
1 : $1.64
10 : $1.41
25 : $1.3
50 : $1.18
100 : $1.05
500 : $0.976
1,000 : $0.929
2,500 : $0.859
126
RFC0807B-475KE

Coilcraft Inc |Coilcraft RFC0807B-475KE
RoHS : Compliant
1 : $1.16
10 : $0.994
25 : $0.911
50 : $0.822
100 : $0.733
500 : $0.683
1,000 : $0.651
2,500 : $0.602
103
RFC1010B-186KE

Coilcraft Inc |Coilcraft RFC1010B-186KE
RoHS : Compliant
1 : $1.63
10 : $1.4
25 : $1.31
50 : $1.18
100 : $1.04
500 : $0.989
1,000 : $0.939
2,500 : $0.89
77
FCA-S2SR-FCASCA-01M

L-com Inc Cable Assy, L-Com Fca-S2Sr-Fcasca-01M; |L-Com FCA-S2SR-FCASCA-01M
RoHS : Not Compliant
1 : $11.16
5 : $10.32
10 : $9.77
25 : $9.12
50 : $8.55
100 : $7.6
250 : $7.29
11
FCA-S1SR-FCFC-15M

L-com Inc Fc/Fc 9/125 Singlemode Simplex Fiber Pat; |L-Com FCA-S1SR-FCFC-15M
RoHS : Not Compliant
1 : $17.93
10 : $17.09
25 : $16.09
50 : $15.19
100 : $14.89
250 : $14.58
8
FCA-S2SR-FCAFCU-05M

L-com Inc Fc-Apc To Fc-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCAFCU-05M
RoHS : Not Compliant
1 : $11.41
10 : $10.65
25 : $9.98
50 : $8.88
100 : $8.52
250 : $8.35
500 : $8.18
4
RFC1010B-474KE

Coilcraft Inc |Coilcraft RFC1010B-474KE
RoHS : Compliant
1 : $1.63
10 : $1.4
25 : $1.31
50 : $1.18
100 : $1.04
500 : $0.989
1,000 : $0.939
2,500 : $0.89
3
FCA-S2SR-FCASCA-02M

L-com Inc Fc-Apc To Sc-Apc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASCA-02M
RoHS : Not Compliant
1 : $9.88
10 : $9.22
25 : $8.64
50 : $7.68
100 : $7.37
250 : $7.22
500 : $7.08
1

RS
RFC-2216

Quest Technology International Inc CABLE ASSEMBLY, UHF PLUG X2, RG-58A/U CBL, 10FT., NON BOOTED
1 : $39.6
44
CRF-CX

ILME UK Ltd ACCESSORY, STAINLESS STEEL FEMALE CODING PIN FOR MIXO
1 : $1.8
50 : $1.62
100 : $1.53
250 : $1.48
500 : $1.43
28
RFC-1326

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG, BNC JACK, RG-59B/U CBL,10FT.,BLACK, UL STDS, NON BOOTED
1 : $6.29
13
RT-120E-R+FC015

PATLITE Corporation REVOLVING LIGHT, 162MM, 32 SOUND HORN, 105DB, 4 CHANNEL, 120VAC, BEIGE, RED
1 : $580.27
3 : $551.25
7
RFC-2215

Quest Technology International Inc CABLE ASSEMBLY, UHF PLUG X2, RG-58A/U CBL, 7FT.
1 : $18.8
5
RFC-1813

Quest Technology International Inc CABLE ASSEMBLY, N PLUG X2, RG-58A/U CBL, 36"
1 : $10.7
2
RT-24E-R+FC015

PATLITE Corporation ROTATING BEACON WITH 8-CHANNEL ALARM WITH 32 PRE-PROGRAMMED SOUNDS; RED
1 : $571.87
3 : $543.27
2
RFC-1112

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG X2, RG-58A/U CBL, 24", BLACK, UL STDS, NON BOOTED
1 : $4.95
1
RFC-1114

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG X2, RG-58A/U CBL, 5FT., BLACK, UL STDS, NON BOOTED
1 : $5.58
1
RFC-1533

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-58C/U CBL, 36", NON BOOTED
1 : $6.15
1
DGRF-C-GF-25-50-P

Festo GUIDED ACTUATOR
1 : $535.72
1
HBL2172RFC2I

Hubbell Wiring Device-Kellems RF CTRL Hospital GradeR, FULL CTRLD, 15A, 5 15R, IV
1 : $190.4
5 : $178.98
10 : $173.26
0
HBL2182RFC1I

Hubbell Wiring Device-Kellems RF CTRL Hospital GradeR, SPLT CIRC, 20A, 5 20R, IV
1 : $204.0
5 : $191.76
10 : $185.64
0
CAS17C471JARFC

KEMET Corporation CAPACITOR, FILM, SFTY 1808 470PF X1 250 / Y2 250 X7R, REEL
RoHS : Compliant
1,000 : $0.81
2,000 : $0.79
0
GRFC207D-35MM (PER.GRFC207)

PEER Bearing Company PEER MOUNTED COMPONENTS (MC)
1 : $56.15
0

STMicroelectronics
SPSGRFC-868

STMicroelectronics Sub-1 GHz (433, 868 or 915 MHz) programmable transceiver module with UFL connector
RoHS : Compliant
1 : $17.49
10 : $15.71
25 : $14.47
100 : $13.38
288 : $12.76
24
SPSGRFC-915

STMicroelectronics Sub-1 GHz (433, 868 or 915 MHz) programmable transceiver module with UFL connector
RoHS : Compliant
1 : $17.52
10 : $16.11
25 : $15.45
100 : $13.61
288 : $12.94
0
SPSGRFC-433

STMicroelectronics Sub-1 GHz (433, 868 or 915 MHz) programmable transceiver module with UFL connector
RoHS : Compliant
1 : $11.02
10 : $10.3
25 : $10.23
50 : $10.23
100 : $10.07
250 : $9.9
500 : $9.74
0

Microchip Technology Inc
INTRFCEV

Microchip Technology Inc Power Supply and Interface Noise Board, Projected EOL:
1 : $83.48
3
MRFC545

Microchip Technology Inc 200MHZ, CW, 25V, PNP Power Transistor, DIE, Projected EOL: 2051-10-27 - Contact for Pricing
0
MRFC544

Microchip Technology Inc 200MHZ, CW, 25V, NPN Power Transistor, DIE, Projected EOL: 2051-10-27 - Contact for Pricing
0

Bisco Industries
MS28774-446 - SCARF CUT

MS O-RINGS
39
RFCAERNFTF

MISC. INDUSTRIAL CONNECTORS
2
MIL-S-22473 SURF COND

Military Specifications
1
Z-RFC-P30

MISCELLANEOUS
1

Rochester Electronics
NCP392ARFCCT1G

onsemi Power Distribution Switch General Purpose N-Channel 1 12-BGA T/R
RoHS : Compliant
100,000 : $0.3474
10,000 : $0.4146
1,000 : $0.465
500 : $0.5043
100 : $0.5603
1,157,125
NCP456RFCCT2G

onsemi Power Distribution Switch General Purpose N-Channel 1 OUT High Side 6-BGA T/R
RoHS : Compliant
100,000 : $0.206
10,000 : $0.2459
1,000 : $0.2758
500 : $0.2991
100 : $0.3323
21,000
NCP392CRFCCT1G

onsemi Specialized Power Management Overvoltage Protection Controller 12-BGA T/R
RoHS : Compliant
100,000 : $0.3474
10,000 : $0.4146
1,000 : $0.465
500 : $0.5043
100 : $0.5603
219,000
NCP392DRFCCT1G

onsemi Specialized Power Management Overvoltage Protection Controller 12-BGA T/R
RoHS : Compliant
100,000 : $0.344
10,000 : $0.4106
1,000 : $0.4605
500 : $0.4993
100 : $0.5548
93,708
NCP458RFCT2G

onsemi Power Distribution Switch General Purpose N-Channel 1 OUT High Side 8-BGA T/R
RoHS : Compliant
100,000 : $0.2211
10,000 : $0.2639
1,000 : $0.296
500 : $0.3209
100 : $0.3566
16,835
AUIRFC8407TR

Infineon Technologies AG MOSFET N-Channel 306A Die
RoHS : Not Compliant
100,000 : $0.4095
10,000 : $0.4888
1,000 : $0.5482
500 : $0.5944
100 : $0.6605
116,606
DDB2U60N12W3RFC39BPSA1

Infineon Technologies AG IGBT MOD 950V 135A 20mW Tray
RoHS : Compliant
1,000 : $126.47
500 : $130.79
100 : $135.1
25 : $139.41
1 : $143.72
568
IRFC4110EB

Infineon Technologies AG MOSFET
0
DDB2U80N12W3RFC39BPSA1

Infineon Technologies AG DDB2U80N12W3RFC39BPSA1
RoHS : Compliant
1,000 : $123.81
500 : $128.03
100 : $132.25
25 : $136.47
1 : $140.69
72
AUIRFC8407TR

International Rectifier MOSFET N-Channel 306A Die
RoHS : Not Compliant
100,000 : $0.4095
10,000 : $0.4888
1,000 : $0.5482
500 : $0.5944
100 : $0.6605
306,276
ISL9000IRFCZ

Intersil Corporation IC VOLT REG Fixed 2 REG 1.8V, 2.5V 300mA, 300mA 10-SON
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
19
ISL9014IRFCZ

Intersil Corporation IC VOLT REG Fixed 2 REG 2.5V, 1.8V 300mA 10-SON Tube
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
42
ISL9014IRFCZ-T

Intersil Corporation IC VOLT REG Fixed 2 REG 2.5V, 1.8V 300mA 10-SON T/R
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
5,950
DF2646RFC20J

Renesas Electronics Corporation IC MCU H8S/2600 16Bit 1 Core FLASH 128kB (128k x 8) 20MHz 144-QFP
RoHS : Compliant
10,000 : $22.49
1,000 : $23.89
500 : $25.3
100 : $26.7
25 : $28.11
13
M3030RFCPGP#U5

Renesas Electronics Corporation IC MCU 16BIT 128KB FLASH 48LQFP
RoHS : Compliant
10,000 : $7.15
1,000 : $7.6
500 : $8.05
100 : $8.49
25 : $8.94
1,734

Sager
RFC500-16

ABB Group CU CRAB CONN ROLLBK INS COMP 500 16
5 : $4,528.3
0
HBL2172RFC2I

Hubbell Incorporated RF CTRL HGR, FULL CTRLD, 15A, 5-15R, IV
1 : $182.28
4 : $174.79
0
HBL2182RFC1I

Hubbell Incorporated RF CTRL HGR, SPLT CIRC, 20A, 5-20R, IV
1 : $194.85
4 : $186.85
0
ROCKERVVEORFCC00-000

Carling Technologies Switch Actuators
1 : $2.83
68 : $2.59
170 : $2.39
417 : $1.74
833 : $1.58
1,667 : $1.53
0
ROCKERVVEORFCY00-000

Carling Technologies Switch Actuators
1 : $2.83
68 : $2.59
170 : $2.39
417 : $1.74
833 : $1.58
1,667 : $1.53
0
HBL2172RFC1W

Hubbell Incorporated RF CTRL HGR, SPLT CIRC, 15A, 5-15R, WH
1 : $190.15
4 : $182.33
0
HBL2172RFC2GY

Hubbell Incorporated RF CTRL HGR, FULL CTRLD, 15A, 5-15R, GY
1 : $182.28
4 : $174.79
0
HBL5362RFC2

Hubbell Incorporated RF CTRL RCPT, FULL CTRLD, 20A, 5-20R, BR
1 : $158.72
5 : $152.2
0
HRFC-AT5K-A15A(60)

Hirose Electric Co Ltd Fiber Optic Connectors
0
HBL5262RFC2W

Hubbell Incorporated RF CTRL RCPT, FULL CTRLD, 15A, 5-15R, WH
1 : $160.75
3 : $151.57
5 : $145.33
0
HBL5362RFC1BK

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 20A, 5-20R, BK
1 : $166.57
5 : $159.73
0
HBL5362RFC1LA

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 20A, 5-20R, LA
1 : $166.57
5 : $159.73
0
HRFC-P12-H(60)

Hirose Electric Co Ltd Fiber Optic Connectors CONN PLUG HOUSING
0
HBL5362RFC1I

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 20A, 5-20R, IV
1 : $166.57
5 : $159.73
0
HBL5362RFC1W

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 20A, 5-20R, WH
1 : $166.57
5 : $159.73
0

Coilcraft Direct
RFC1010B-275KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.39
150 : $1.14
300 : $0.86
600 : $0.51
1,050 : $0.4
2,550 : $0.34
501
RFC1010B-823KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.39
150 : $1.14
300 : $0.86
600 : $0.51
1,050 : $0.4
2,550 : $0.34
162
RFC0810B-474KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
151
RFC0810B-104KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
44
RFC1010B-334KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.39
150 : $1.14
300 : $0.86
600 : $0.51
1,050 : $0.4
2,550 : $0.34
42
RFC0807B-274KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
16
RFC0807B-824KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
6
RFC0810B-824KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
6
RFC0810B-393KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
5
RFC0807B-335KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
0
RFC0807A-105KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
0
RFC0807B-564KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
0
RFC0810B-186KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
0
RFC0810A-105KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
0
RFC0810B-184KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
0

TME
CAS26C152KARFC

YAGEO Corporation Capacitor: ceramic; 1.5nF; 250VAC; X7R; ±10%; SMD; 2211; Thk: 2.794mm
RoHS : Compliant
500 : $0.83
500
SPSGRFC-868

STMicroelectronics U.FL; GFSK,GMSK,OOK; 868MHz; SPI; -118dBm; 11.6dBm; SMD; 500kbps
RoHS : Compliant
144 : $12.69
288
RF-C37D0-UTP-AR

Shenzhen Refond Optoelect LED; UV-B; 120°; 80mA; 800mW; λd: 305÷311nm; 4.5÷7.5VDC; SMD
100 : $4.08
25 : $4.35
5 : $4.62
1 : $4.9
281
TLP785(GR.F(C

Toshiba America Electronic Components Optocoupler; THT; Ch: 1; OUT: transistor; Uinsul: 5kV; Uce: 80V; DIP4
1,000 : $0.249
300 : $0.291
50 : $0.375
10 : $0.438
2 : $0.61
207
RFCT-N-CAP-GS-1

Global Connector Technology Protection cover; IP67; chain; Application: N socket
RoHS : Compliant
500 : $3.52
250 : $3.65
100 : $3.89
50 : $4.07
25 : $4.25
10 : $4.49
1 : $5.27
170
RF-C37N0-URT-AR

Shenzhen Refond Optoelect LED; UV-C; 120°; 80mA; 800mW; λd: 270÷280nm; 4.5÷7.5VDC; SMD
25 : $2.28
5 : $2.74
1 : $3.04
117
RFC570M-EIW-DRS

Raystar Optronics Inc Display: TFT; 5.7"; 320x240; Illumin: LED; Dim: 141.12x101.55x15mm
5 : $107.0
3 : $115.0
1 : $131.0
11
RFC350M-EIW-DRS

Raystar Optronics Inc Display: TFT; 3.5"; 320x240; Illumin: LED; Dim: 100x66.44x8.9mm; RGB
10 : $31.8
3 : $33.0
1 : $34.2
10
RF-C37P0-URF-AR

Shenzhen Refond Optoelect LED; UV-C; 120°; 350mA; 3.8W; λd: 270÷280nm; 4.5÷7.5VDC; SMD
25 : $16.0
5 : $17.6
1 : $19.2
7
RFC570E-AIW-DNS

Raystar Optronics Inc Display: TFT; 5.7"; 320x240; Illumin: LED; Dim: 141.12x101.55x8mm
5 : $42.48
3 : $42.6
1 : $44.4
5
RFC02MM2STFTR

ROHM Semiconductor Diode: rectifying; SMD; 200V; 0.2A; 35ns; SOD123F; Ufmax: 0.95V
RoHS : Compliant
6,000 : $0.139
3,000 : $0.143
1,000 : $0.148
500 : $0.153
100 : $0.169
10 : $0.206
1 : $0.26
0
CAS17C102KARFC

KEMET Corporation Capacitor: ceramic; X1/Y2; 1nF; 250VAC; X7R; ±10%; SMD; 1808
RoHS : Compliant
5,000 : $0.576
3,000 : $0.583
2,000 : $0.598
1,000 : $0.62
1 : $1.55
0
RF-CC1101-868

Radiocontrolli Module: RF; 868MHz; SPI; -112dBm; 1.8÷3.6VDC; 12dBm; SMD; 16x9mm
25 : $13.48
5 : $15.72
1 : $16.51
0
RF-CC1310-AT

Radiocontrolli Module: RF; 868/915MHz; SPI; -124dBm; 1.8÷3.8VDC; 14dBm; SMD; SMA
25 : $10.95
5 : $12.58
1 : $13.48
0
CAS18C102KARFC

KEMET Corporation Capacitor: ceramic; X1/Y2; 1nF; 250VAC; X7R; ±10%; SMD; 1812
RoHS : Compliant
10,000 : $1.03
1,000 : $1.11
500 : $1.16
250 : $1.21
100 : $1.31
50 : $1.44
10 : $1.84
5 : $2.07
1 : $2.53
0

Ameya Holding Limited
RFC02MM2STR

ROHM Semiconductor 超快速恢复二极管
RoHS : Compliant
1 : $0.46
10 : $0.352
100 : $0.22
500 : $0.15
1,000 : $0.116
3,000 : $0.104
65

ComSIT USA
ADM809XCSURFCAM

Analog Devices Inc Electronic Component
RoHS : Not Compliant
20,000
MFR3100RFC

TT Electronics Welwyn Components Fixed Resistor, Metal Film, 0.4W, 100ohm, 200V, 1% +/-Tol, 50ppm/Cel, Through Hole Mount
RoHS : Compliant
15,000
3301C44RRFCD1T1U1CHAM

Everlight Electronics Co Ltd DIA 3 PIRANHA LED Single Color LED, Red, Water Clear Colorless, T-1, 3mm
RoHS : Compliant
5,360
MFR3422RFC

TT Electronics Welwyn Components Fixed Resistor, Metal Film, 0.4W, 422ohm, 200V, 1% +/-Tol, 50ppm/Cel, Through Hole Mount
RoHS : Compliant
5,000
SAKC164CW4RFCA

Infineon Technologies AG Electronic Component
RoHS : Compliant
4,687
SAKC164SM4RFCA

Infineon Technologies AG 16-BIT SINGLE-CHIP MICROCONTROL LER Microcontroller, CMOS
RoHS : Compliant
1,900
AUIRFC3805TR

International Rectifier Electronic Component
RoHS : Not Compliant
1,000

GLYN GmbH & Co. KG
CAB-GRE-RFC7_KABEL_Y

Great Ideal Co Ltd IDC 2.54-2*5P TO 51021-0800 & A1255H-06P Wireÿ:U
2

Interstate Connecting Components
PKT06RFC24-10PW

Amphenol Aerospace 5015 STR PLG 7#8 PIN 'W' ENP
0
MFM072RFC011

Amphenol PCD FIBRE
0
PKB06RFC22-22R

Amphenol Aerospace 5015 HIGH PWR W/ BAYONET COUP STR PLUG 4#8 RADSOK ENP
0
PKT00RFC28-22P

Amphenol Aerospace 5015 PWR WLL MNT RCP 3#4 3#16 PIN ENP
0
PKT06RFC22-22P

Amphenol Aerospace 5015 HIGH POWER STR PLG 4#8 PIN ENP
0
MFM002RFC

Amphenol PCD FIBRE
0
PKT00RFC24-10SW

Amphenol Aerospace 5015 PWR WLL MNT RCP 7#8 SKT 'W' ENP
0
PKT06RFC36-6T

Amphenol Aerospace PWR 5015 THR COUP STR PLG 4#6 SKT ENP
0
PKT07RFC22-6T

Amphenol Aerospace 5015 JAM NUT RCP 2#8 1#16 TEMP GRIP SKT ENP
0
MFM062RFC

Amphenol PCD FIBRE
0
PKT06RFC28-10S

Amphenol Aerospace 5015 STR PLG 2#4 2#8 3#12 SKT ENP
0
PKT06RFC32-15R

Amphenol Aerospace PK SKT TEMPER GRIP CONNECTORS
0
PKT00RFC28-22PX

Amphenol Aerospace 5015 PWR WLL MNT RCP 3#4 3#16 PIN 'X' ENP
0
PKT07RFC24-10SW

Amphenol Aerospace 5015 JAM NUT RCP 7#8 SKT 'W' ENP
0
PKT06RFC24-10S

Amphenol Aerospace 5015 STR PLG 7#8 SKT ENP
0

NexGen Digital
RFCS04025600CJTT1

Vishay Huntington
2,587

PEI Genesis
PKB05RFC24-12PY

Amphenol Corporation
1 : $0.0
10 : $0.0
25 : $0.0
50 : $0.0
100 : $0.0
0
PKB05RFC24-12PX

Amphenol Corporation
1 : $0.0
10 : $0.0
25 : $0.0
50 : $0.0
100 : $0.0
0

Richardson RFPD
INTRFCEV

Microchip Technology Inc Power Supply And Interface Noise Board
RoHS : Compliant
19 : $95.3
0
P2RFC-2275-420

RF Industries CBL ASSY; 4.3/10 MALE TO 4.3/10 MALE; TFT-402LF; P
RoHS : Not Compliant
0
P2RFC-2275-540

RF Industries CBL ASSY; 4.3/10 MALE TO 4.3/10 MALE; TFT-402LF; P
RoHS : Not Compliant
19 : $154.45
0

Chip 1 Exchange
D12931RFCS

INSTOCK
5,000
D25210RFCS

Vishay Roederstein INSTOCK
5,000
D25210RFCS

Vishay Roederstein INSTOCK
5,000
D25820RFCS

Vishay Roederstein INSTOCK
5,000
D25511RFCS-1

INSTOCK
5,000
D25732RFCS

Vishay Roederstein INSTOCK
5,000
D12681RFCS

Vishay Intertechnologies INSTOCK
5,000
D12681RFCS

Vishay Intertechnologies INSTOCK
5,000
D12124RFCS

Vishay Draloric INSTOCK
4,950
D25604RFC

Vishay Roederstein INSTOCK
3,345
D12261RFCS

INSTOCK
2,970
D25215RFCS

Vishay Roederstein INSTOCK
2,715
D25150RFCS

INSTOCK
2,660
D25649RFCS

Vishay Roederstein INSTOCK
2,170
RFC16474F

Dubilier INSTOCK
1,500

Avnet Abacus
H882RFCA

TE Connectivity Resistor 82 Ohm 1 250 mW Axial Leaded Metal Film Precision (Alt: 2-1879625-3)
RoHS : Compliant
0
H4P33RFCA

TE Connectivity Resistor 33 Ohm 1 1 W Axial Leaded Metal Film Precision (Alt: 1-1879621-3)
RoHS : Compliant
0
ACCRFCL13BB1

Vishay Intertechnologies VISACCRFCL13BB1 (Alt: ACCRFCL13BB1)
RoHS : Compliant
0
228BDVARFCFG

CTS Corporation (Alt: 228BDVARFCFG)
RoHS : Compliant
0
228ADS2ARFCRC

CTS Corporation (Alt: 228ADS2ARFCRC)
RoHS : Compliant
0
228AMVARFCWDR

CTS Corporation (Alt: 228AMVARFCWDR)
RoHS : Compliant
0
CAS17C471JARFC

KEMET Corporation Ceramic Suppression Capacitor 470 pF 5 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C471JARFC)
RoHS : Compliant
0
CAS17C821MARFC

KEMET Corporation Ceramic Suppression Capacitor 820 pF 20 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C821MARFC)
RoHS : Compliant
0
CAS18C681JARFC

KEMET Corporation Ceramic Suppression Capacitor 680 pF 5 X1 Y2 250 VAC 250 VAC 1812 4532 Metric (Alt: CAS18C681JARFC)
RoHS : Compliant
0
CAS17C101MARFC

KEMET Corporation Ceramic Suppression Capacitor 100 pF 20 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C101MARFC)
RoHS : Compliant
0
CAS21C821KARFC

KEMET Corporation Ceramic Suppression Capacitor 820 pF 10 X1 Y2 250 VAC 250 VAC 2220 5650 Metric (Alt: CAS21C821KARFC)
RoHS : Compliant
0
CAS26C181MARFC

KEMET Corporation Ceramic Suppression Capacitor 180 pF 20 X1 Y2 250 VAC 250 VAC 2211 5728 Metric (Alt: CAS26C181MARFC)
RoHS : Compliant
0
228ADS2ARFCBBC

CTS Corporation (Alt: 228ADS2ARFCBBC)
RoHS : Compliant
0
228ADS2ARFCMSE

CTS Corporation (Alt: 228ADS2ARFCMSE)
RoHS : Compliant
0
228AMVARFCMBBR

CTS Corporation (Alt: 228AMVARFCMBBR)
RoHS : Compliant
0

Avnet Asia
CAS17C102KARFC

KEMET Corporation Ceramic Suppression Capacitor, 1000 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] (Alt: CAS17C102KARFC)
RoHS : Compliant
0
CAS21C472KARFC

KEMET Corporation Ceramic Suppression Capacitor, 4700 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2220 [5650 Metric] (Alt: CAS21C472KARFC)
RoHS : Compliant
0
TLP785(GR,F(C

Toshiba America Electronic Components (Alt: TLP785(GR,F(C)
RoHS : Compliant
0
R5F10RFCAFP#50

Renesas Electronics Corporation MCU 16-Bit RL78 CISC 32KB Flash 1.6V to 5.5V 44-Pin LQFP Tray (Alt: R5F10RFCAFP#50)
RoHS : Compliant
0
NCP456RFCCT2G

onsemi Load Switch, 2 A Single, For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
R5F10RFCAFP#10

Renesas Electronics Corporation Microcontroller 16-Bit RL78 CISC 32KB Flash 44-Pin LQFP (Alt: R5F10RFCAFP#10)
RoHS : Compliant
0
CAS17C331KARFC

KEMET Corporation Ceramic Suppression Capacitor, 330 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] (Alt: CAS17C331KARFC)
RoHS : Compliant
50,000 : $0.50863
25,000 : $0.52167
10,000 : $0.53539
5,000 : $0.54986
3,000 : $0.5574
2,000 : $0.56514
1,000 : $0.5731
0
QTLP650C4TR/FC15-21SYGC/S530-E2/TR8

Everlight Electronics Co Ltd (Alt: QTLP650C4TR/FC15-21SYGC/S530-E2/TR8)
RoHS : Compliant
0
CAS17C102MARFC

KEMET Corporation (Alt: CAS17C102MARFC)
RoHS : Compliant
0
CAS18C102KARFC

KEMET Corporation (Alt: CAS18C102KARFC)
RoHS : Compliant
0
CAS26C222KARFC

KEMET Corporation Ceramic Suppression Capacitor, 2200 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2211 [5728 Metric] (Alt: CAS26C222KARFC)
RoHS : Compliant
0
RFCM3327TR13

Qorvo (Alt: RFCM3327TR13)
RoHS : Compliant
0
TC75W71FU,RF(CB

Toshiba America Electronic Components TOSTC75W71FU,RF(CB CMOS LINEAR IC (Alt: TC75W71FU,RF(CB)
RoHS : Compliant
0
RFCM3328TR13

Qorvo (Alt: RFCM3328TR13)
RoHS : Compliant
0
QTLP601C4TR/FC19-213SYGC/S530-E2/TR8

Everlight Electronics Co Ltd (Alt: QTLP601C4TR/FC19-213SYGC/S530-E2/TR8)
RoHS : Compliant
0

Avnet Silica
1320XRFC

NXP Semiconductors Daughter Card RF Zigbee Communication Networking MC9S08 (Alt: 1320XRFC)
RoHS : Compliant
0
SRFC015-100

Antenova M2M Zhengi flexible antenna 100mm cable Ipex Cellular 3G 4G and LTE (Alt: SRFC015-100)
RoHS : Compliant
0
SRFC025-100

Antenova M2M AVIA 3G FLEXIBLE ANTENNA 100mm cable (Alt: SRFC025-100)
RoHS : Compliant
0
SRFC025-200

Antenova M2M AVIA 3G FLEXIBLE ANTENNA 200mm cable (Alt: SRFC025-200)
RoHS : Compliant
0
RFCM3328TR13

Qorvo (Alt: RFCM3328TR13)
RoHS : Compliant
0
NCP456RFCCT2G

onsemi Load Switch 2 A Single For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
RFC02MM2STFTR

ROHM Semiconductor Super Fast Recovery Diode 200V 500mA 2Pin SOD123L TR (Alt: RFC02MM2STFTR)
RoHS : Compliant
0
M3030RFCPGP#33

Renesas Electronics Corporation 16BIT MCU M16C30P (Alt: M3030RFCPGP#33)
RoHS : Compliant
0
R5F10RFCGFP#50

Renesas Electronics Corporation (Alt: R5F10RFCGFP#50)
RoHS : Compliant
0
R5F10RFCAFP#50

Renesas Electronics Corporation (Alt: R5F10RFCAFP#50)
RoHS : Compliant
0
R5F10RFCAFP#10

Renesas Electronics Corporation (Alt: R5F10RFCAFP#10)
RoHS : Compliant
0
STM32WC-RFCKIT

STMicroelectronics Development Kit For STM32W RF Wireless Control (Alt: STM32WC-RFCKIT)
RoHS : Compliant
0

Component Electronics, Inc
D11010RFCS

Vishay Intertechnologies IN STOCK SHIP TODAY
1,000 : $0.08
100 : $0.09
1 : $0.12
3,000
RFC-8716-60

RF CONN IN STOCK SHIP TODAY
1,000 : $17.5
100 : $20.19
1 : $26.92
117
RFC-8715-14

RF CONN IN STOCK SHIP TODAY
1,000 : $10.0
100 : $11.54
1 : $15.38
46
RFC-8714-60

RF CONN IN STOCK SHIP TODAY
1,000 : $12.5
100 : $14.42
1 : $19.23
46
RFC1010B-104KE

Coilcraft Inc IN STOCK SHIP TODAY
RoHS : Compliant
1,000 : $1.0
100 : $1.15
1 : $1.54
10
SR-FC-HUB

IN STOCK SHIP TODAY
5
194R-FCA2

AB Connectors Ltd IN STOCK SHIP TODAY
1,000 : $25.0
100 : $28.85
1 : $38.46
3

EBV Elektronik
TLP785F(GR,F(C

Toshiba America Electronic Components Optocoupler 1CH Open Collector 5000Vrms 4Pin DIP Tube (Alt: TLP785F(GR,F(C)
RoHS : Compliant
10,600
TLP785(GR,F(C

Toshiba America Electronic Components Optocoupler DCIN 1CH Transistor DCOUT 4Pin DIP (Alt: TLP785(GR,F(C)
RoHS : Compliant
3,400
TLP785(D4-GR,F(C

Toshiba America Electronic Components Optocoupler DCIN 1CH DCOUT 4Pin PDIP SMD (Alt: TLP785(D4-GR,F(C)
RoHS : Compliant
1,600
NCP456RFCCT2G

onsemi Load Switch 2 A Single For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
M3030RFCPGP#35

Renesas Electronics Corporation 16BIT MCU M16C30P (Alt: M3030RFCPGP#35)
RoHS : Compliant
0
CL8068404069418S RFCP

Intel Corporation Intel Core i79750H Processor 12M Cache up to 450 GHz FCBGA14F Tray (Alt: 999CXN)
RoHS : Compliant
0
CL8068404069606S RFCR

Intel Corporation Intel Core i59300H Processor 8M Cache up to 410 GHz FCBGA14F Tray (Alt: 999CXR)
RoHS : Compliant
0

FDH Electronics
PKB06RFC24-10T

Amphenol Aerospace Circular Conn
13
PKT07RFC20-22P

Amphenol Aerospace Circular Conn
5
PKB06RFC24-12T

Amphenol Aerospace Circular Conn
5
RFC1035-116 ISS A

W L Gore & Associates Cable Assembly
1 : $4,302.222
5 : $4,302.222
10 : $3,951.02
25 : $3,396.491
50 : $3,396.491
100 : $3,281.356
250 : $3,173.77
500 : $3,173.77
1,000 : $3,173.77
2,500 : $3,173.77
10,000 : $3,173.77
3
PKT06RFC20-22T

Amphenol Aerospace Circular Conn
3
PERF CARD STK

FDH Electronics Wire Placehldr
2

Flip Electronics
R5F10RFCAFP#10

Renesas Electronics Corporation Stock
RoHS : Compliant
3,840
R5F10RFCAFP#30

Renesas Electronics Corporation Stock
RoHS : Compliant
1,221

TE Connectivity
6ESRFC3

TE Connectivity 6ESRFC3=F6987 Current Rating: 15 A Filter Connector Type: IEC 60320-1 C-13 Filter Connector Style: Female Receptacle Output Termination Type: 1/4" Faston Iec Unfiltered Inlets & Corcom Sr Series | 15 A IEC 60320-1 C-13 Female Receptacle 1/4" Faston | Part Number: 6ESRFC3 | Internal Number: 1609133-2 | TE Connectivity
RoHS : Compliant
500 : $5.74
250 : $5.94
100 : $6.14
50 : $6.33
25 : $6.53
10 : $6.73
1 : $6.93
1,544

Venkel Ltd.
RFCA1206K1T

VENKEL LTD RF Ceramic Antenna;1206;5GHz
RoHS : Not Compliant
0
RFCA1206A5T

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA1206Y1T

VENKEL LTD RF Ceramic Antenna;1206;7.37GHz
RoHS : Not Compliant
0
RFCA1206A1T

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA3224YAT

VENKEL LTD RF Ceramic Antenna;3224;6.5GHz
RoHS : Not Compliant
0
RFCA0402A1T

VENKEL LTD RF Ceramic Antenna;0402;2.45GHz
RoHS : Not Compliant
0
RFCA0805A0T

VENKEL LTD RF Ceramic Antenna;0805;2.45GHz
RoHS : Not Compliant
0
RFCA0805A3T

VENKEL LTD RF Ceramic Antenna;0805;2.4GHz
RoHS : Not Compliant
0
RFCA1206AAT

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA3708A0T

VENKEL LTD RF Ceramic Antenna;3708;2.4GHz
RoHS : Not Compliant
0
RFCA1206E0T

VENKEL LTD RF Ceramic Antenna;1206;1.575GHz
RoHS : Not Compliant
0

Vyrian
CAS21C472KARFC

KEMET Corporation Ceramic Capacitor, Multilayer, Ceramic, 10% +Tol, 10% -Tol, X7R, 15% TC, 0.0047uF, Surface Mount, 2220
17,124
CAS17C102MARFC

KEMET Corporation Ceramic Capacitor, Multilayer, Ceramic, 20% +Tol, 20% -Tol, X7R, 15% TC, 0.001uF, Surface Mount, 1808
15,432
RFC0807BV-105KE

Coilcraft Inc General Purpose Inductor, 1000uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
15,002
NCP458RFCCT2G

onsemi Buffer/Inverter Based Peripheral Driver, 1 Driver, PBGA8
RoHS : Compliant
11,589
RFC0807BV-154KE

Coilcraft Inc General Purpose Inductor, 150uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
9,964
NCP392ARFCCT1G

onsemi Power Supply Support Circuit, Adjustable, 1 Channel, PBGA12
RoHS : Compliant
9,755
CAS17C102KARFC

KEMET Corporation Ceramic Capacitor, Multilayer, Ceramic, 10% +Tol, 10% -Tol, X7R, 15% TC, 0.001uF, Surface Mount, 1808
7,959
VT451RFCR-ADJ

Analog Devices Inc
5,261
XQVU095-1RFC1517I

AMD Xilinx Field Programmable Gate Array, 1176000-Cell, PBGA1517
RoHS : Not Compliant
3,989
XQVU065-2RFC1517E

AMD Xilinx Field Programmable Gate Array, 783300-Cell, PBGA1517
RoHS : Not Compliant
2,845
XQVU065-1RFC1517I

AMD Xilinx Field Programmable Gate Array, 783300-Cell, PBGA1517
RoHS : Not Compliant
2,600
XQVU095-2RFC1517E

AMD Xilinx Field Programmable Gate Array, 1176000-Cell, PBGA1517
RoHS : Not Compliant
1,987
XQVU095-1RFC1517M

AMD Xilinx Field Programmable Gate Array, 1176000-Cell, PBGA1517
RoHS : Not Compliant
1,593
MFC-20KRFC

Honda Tsushin Kogyo Board Connector, 20 Contact(s), 2 Row(s), Female, 0.1 inch Pitch, Black Insulator, Plug
780
HD64F2646RFC20JV

Renesas Electronics Corporation Microcontroller
328

Win Source Electronics
RFCMF1220100M3T

Walsin Technology Corporation CMC 300MA 2LN 80 OHM SMD
RoHS : Compliant
1,440 : $0.2084
1,080 : $0.2325
835 : $0.2405
605 : $0.2485
390 : $0.2565
160 : $0.3126
51,804
HI3559RFCV100

HiSilicon Technologies Co Ltd SoC Processor for Video Surveillance
5 : $69.4657
4 : $77.481
3 : $80.1527
2 : $82.8245
1 : $85.4962
2,000
HI3516ARFCV200

HiSilicon Technologies Co Ltd
4 : $85.3272
3 : $95.1726
2 : $98.4544
1 : $101.7362
355
HI3521RFCV100

HiSilicon Technologies Co Ltd
10 : $33.116
7 : $36.937
6 : $38.2107
4 : $39.4844
3 : $40.7581
2 : $49.6739
268

Link URL



Lei ha avuto il aiuto da alldatasheet?  [ DONATE ]  

Di alldatasheet   |   Richest di pubblicita   |   contatti   |   Privacy Policy   |   Collegamento alla scheda tecnica    |   scambio Link   |   Ricerca produttore
All Rights Reserved짤Alldatasheet.com


Mirror Sites
English : Alldatasheet.com  |   English : Alldatasheet.net  |   Chinese : Alldatasheetcn.com  |   German : Alldatasheetde.com  |   Japanese : Alldatasheet.jp
Russian : Alldatasheetru.com  |   Korean : Alldatasheet.co.kr  |   Spanish : Alldatasheet.es  |   French : Alldatasheet.fr  |   Italian : Alldatasheetit.com
Portuguese : Alldatasheetpt.com  |   Polish : Alldatasheet.pl  |   Vietnamese : Alldatasheet.vn
Indian : Alldatasheet.in  |   Mexican : Alldatasheet.com.mx  |   British : Alldatasheet.co.uk  |   New Zealand : Alldatasheet.co.nz
Family Site : ic2ic.com  |   icmetro.com